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In Depth: Impress

Impress is the presentation package within OpenOffice.org. At first glance, it appears to 

be the simplest of the key OpenOffice.org components, and also the one that borrows 

most the look and feel from Microsoft Office. However, delving into its feature set reveals 

more than a few surprises, including sophisticated animation effects and drawing tools. 

Impress can also export presentations as Adobe Flash–compatible files, which means that 

many Internet-enabled desktop computers around the world will be able to view the files, 

even if they don’t have Impress or PowerPoint installed on their computers.

In this chapter, you’ll learn about the main features of Impress, as well as the basics of 

working with presentations. You can start the program by clicking Applications  ➤ Office ➤ 

OpenOffice.org Presentation.

Creating a Quick Presentation
As soon as Impress starts, it will offer to guide you through the creation of a presentation 

using a wizard. This makes designing your document a matter of following a few steps.

You’ll initially be offered three choices: Empty Presentation, From Template, or Open 

Existing Presentation. When Impress refers to templates, it means presentations that are 

both predesigned and also contain sample content. Only two templates are supplied with 

Impress, so this option is somewhat redundant. However, you might choose to look at 

them later, if only to get an idea of what a presentation consists of and how it’s made.

■Tip  When you become experienced in working with Impress, you can create your own templates or down-

load some from the Internet. To create your own template, simply select to save your document as a template 

in the File Type drop-down list in the Save As dialog box. Make sure you place any templates you download 

or create in the /usr/lib/openoffice/share/template/en-US/presnt/ directory (you will need to 

have superuser powers to do this and should make sure the file permissions are readable for all users).
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The standard way of getting started is to create an empty presentation. This sounds 

more daunting than it actually is, because the Presentation Wizard will start, asking you to 

choose from a couple of ready-made basic designs, as shown in Figure 25-1. You’ll also be 

given a chance to choose which format you want the presentation to take: whether it’s 

designed primarily to be viewed on-screen or printed out.

Figure 25-1. The Impress Presentation Wizard guides you through the creation of a new 

presentation.

After this, you’ll be invited to choose the presentation effects, including the transition 

effect that will separate each slide when the presentation is viewed and the speed of the 

transition. If you wish, you can set the pause between slides, too, as well as the length of 

time each slide stays on the screen.

After clicking the Create button in the wizard, Impress will start, and you’ll be invited 

to choose a layout for your initial slide. These are previewed on-screen on the right side of 

the program window. A variety of design templates are available, ranging from those that 

contain mostly text to those that feature pictures and/or graphs.



C HA P TE R  2 5  ■  IN  DE P T H :  IM PR E SS 503

Depending on which template you choose, you should end up with a handful of text 

boxes on your screen. Editing the text in these is simply a matter of clicking within them. 

The formatting of the text will be set automatically.

■Tip  You can move and shrink each text box by clicking the handles surrounding the box. To draw a new 

text box, select the relevant tool on the Drawing toolbar, which runs along the bottom of the screen. Simply 

click and drag to draw a box of whatever size you want.

Working in Impress
When the Presentation Wizard has finished and Impress has started, you’ll notice three 

main elements in the program window, from left to right, as shown in Figure 25-2. You 

work in these panes as follows:

Slides pane: This pane shows the slides in your presentation in order, one beneath 

the other. Simply click to select whichever slide you want to work on, or click and drag 

to reorder the slides. To create a new slide, right-click in a blank area on the Slides 

pane. Right-clicking any existing slide will present a range of options, including one 

to delete the slide.

Main work area: This is in the middle of the program window and lets you edit the 

various slides, as well as any other elements attached to the presentation, such as notes 

or handout documents. Simply click the relevant tab.

Tasks pane: Here, you can access the elements that will make up your presentation, 

such as slide templates, animations, and transition effects. Select the slide you wish to 

apply the elements to in the Slides pane, and then click the effect or template you 

wish to apply in the Tasks pane. In the case of animations or transitions, you can 

change various detailed settings relating to the selected element.

In addition, Impress has a Drawing toolbar, which appears at the bottom of the screen. 

This lets you draw various items on screen, such as lines, circles, and rectangles, and also 

contains a handful of special-effect tools, which we’ll discuss later in this chapter, in the 

“Applying Fontwork” and “Using 3D Effects” sections.

You can hide each on-screen item by clicking the View menu and then removing the 

check next to it. Alternatively, by clicking the vertical borders between each pane, you can 

resize the pane and make it either more or less prominent on screen. This is handy if you wish 

to temporarily gain more work space but don’t want to lose sight of the previews in the Slides 

pane, for example.
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Figure 25-2. The main Impress window is split into three elements: the Slides pane, main 

work area, and the Tasks pane.

Animating Slides
All elements within Impress can be animated in a variety of ways. For example, you might 

choose to have the contents of a particular text box fly in from the edge of the screen 

during the presentation. This can help add variety to your presentation, and perhaps even 

wake up your audience!

Setting an animation effect is simply a matter of clicking the border of the object you 

wish to animate in the main editing area so that it is selected, selecting Custom Animation 

in the Tasks pane, and then clicking the Add button. In the dialog box that appears, select 

how you want the effect to work. As shown in Figure 25-3, you have four choices, each 

with its own tab within the dialog box:

Entrance: This lets you animate an appearance effect for the selected object. For 

example, you can choose to have a text box dissolve into view or fly in from the side of 

the screen. When you select any effect, it will be previewed within the main editing area.
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Emphasis: This gives you control over what, if anything, happens to the object while 

it’s on screen. As the name suggests, you can use this animation to emphasize various 

elements while you’re giving the presentation. Some emphasis effects are more dramatic 

than others, and this lets you control the impact. If you want to make an important 

point, you can use a dramatic effect, while more moderate information is presented with 

a more subdued effect.

Exit: As you might expect, this lets you add an exit animation to the object. You might 

choose to have it fly off the side of the screen or spin away off the top of the screen. 

The animation choices here are identical to the Entrance choices.

Motion path: This makes the selected element fly around on screen according to a 

particular path. For example, selecting Heart will cause the element to fly around 

describing the shape of a heart, eventually returning to its origin. A motion path is 

effectively another way of emphasizing a particular object.

■Note  You can apply only one effect at a time to an object, although several separate effects can be applied 

to any object.

Figure 25-3. A wide variety of animation effects is available for on-screen elements.
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With each animation, you can select the speed you wish it to play at, ranging from Very 

Slow to Fast. Simply make the selection at the bottom of the dialog box.

Once the animation has been defined and you’ve clicked OK, it will appear in a list at 

the bottom of the Custom Animation pane. You can choose to add more than one anima-

tion to an object by clicking the Add button again (ensuring the object is still selected in 

the main editing area). The animations will play in the order they’re listed. You can click 

the Change Order up and down arrows to alter the order.

To fine-tune an effect you’ve already created, double-click it in the list to open its Effect 

Options dialog box (you can even add sound effects here). Under the Timing tab, you can 

control what cues the effect, such as a click of a mouse, or whether it will appear in sequence 

with other effects before or after in the list.

Applying Fontwork
The Fontwork tool lets you manipulate text in various playful ways, such as making it follow 

specific curved paths. You can find this tool on the Drawing toolbar, located at the bottom 

of the program window. It’s the icon that’s an A in a picture frame.

When you click the icon, the Fontwork Gallery dialog box appears, offering a choice of 

predefined font effects. Don’t worry if they’re not quite what you want, because after you 

make a choice, you’ll be invited to fine-tune it.

Once you’ve made the selection, the dummy text “Fontwork” will appear on screen. 

Editing the text is simple: just double-click the “Fontwork” text and type your own words. 

When you’ve finished, click outside the Fontwork selection.

Whenever the new Fontwork item is selected, one or two floating toolbars will appear, 

as shown in Figure 25-4. You can use these toolbars to alter various options. For example, 

you can select a completely different Fontwork selection from the gallery or, by clicking 

the second icon on the left on the Fontwork toolbar, select your own path that you want 

the Fontwork item to follow. If the Fontwork type is three-dimensional, the 3D-Settings 

toolbar will let you alter the perspective, texture, and lighting. For more info on the options 

available, see the “Using 3D Effects” section.

You’ll also see that the Formatting toolbar running along the top of the program 

window changes to allow you to alter the formatting of the Fontwork element. You can 

alter the thickness of the letter outlines, for example, or the color of the letters. Once 

again, the best way to learn how the tool works is to play around with the options and see 

what you can achieve.

To remove a Fontwork item, just select its border and press the Delete key on your 

keyboard.
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Figure 25-4. The Fontwork tool can add some special effects to your presentations.

Using 3D Effects
In addition to Fontwork effects, Impress includes a powerful 3D tool, which can give 

just about any on-screen element a 3D flourish (this tool is also available in some other 

OpenOffice.org applications). To use it, create a text box or shape using the Drawing 

toolbar at the bottom of the screen. Then right-click the text box or shape and select 

Convert ➤ 3D. 

■Note  The 3D option is designed simply to give your object depth. If you want to create a genuine 3D object 

that you can rotate in 3D space, select the 3D Rotation Object.
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You can gain much more control over the 3D effect by right-clicking it and selecting 3D 

Effects. This will open a floating palette window with five configuration panels, as shown 

in Figure 25-5. Click the icons at the top of the palette to adjust the type of 3D effect and 

its lighting, as follows:

Geometry: This defines how the 3D effect will look when it’s applied to on-screen selec-

tions. For example, you can increase or decrease the rounded-edges value, and this 

will make any sharp objects on the screen appear softer when the 3D effect is applied.

Shading: This affects not the actual texture of the 3D object, but instead alters its 

color gradient. This is best demonstrated in action, so select the various shading 

modes from the drop-down list to see the effect. In addition, you can choose whether 

a shadow is applied to the effect, as well as the position of the virtual camera (the 

position of the hypothetical viewer looking at the 3D object).

Illumination: This lets you set the lighting effect. All 3D graphics usually need a light 

source, because this helps illustrate the 3D effect; without a light source, the object 

will appear flat. Various predefined light sources are available. You can click and drag 

the light source in the preview window.

Textures: This affects how the textures will be applied to the 3D object. A texture is 

effectively a picture that is “wrapped around” the 3D object. Clever use of textures 

can add realism to a 3D object. A map of the world applied to a sphere can make it 

look like a globe, for example, or you could add wood or brickwork textures to make 

objects appear as tabletops or walls.

Material: This lets you apply various color overlays on the texture. This can radically 

alter the texture’s look and feel, so it is quite a powerful option. To change the texture 

itself, right-click the object and select Area. This will present a list of predefined 

textures. Alternatively, you can select to use a color or pattern.

To apply any changes you make, click the check button at the top right of the palette. As 

with the other presentation effects, the best policy is simply to experiment until you’re 

happy with the results.
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Figure 25-5. You can fine-tune 3D objects to quite a high degree using the 3D Effects palette.

Exporting a Presentation As a Flash File
If you plan to put your presentation online, or you want to send it to a colleague who 

doesn’t have Impress or PowerPoint installed, outputting your presentation as a Flash 

animation could be a good idea. The process is simple. Just select File ➤ Export, and then 

select Macromedia Flash (SWF) in the File Format drop-down list (SWF is the Flash file 

type, which stands for Shockwave Flash). No further configuration is necessary.

In order to play the file, it needs to be opened within a web browser that has the Flash 

Player installed. This can be done by selecting File ➤ Open on most browsers, although 

you can also drag-and-drop the SWF file onto the browser window under Microsoft 

Windows. There shouldn’t be much of a problem with compatibility, since the Flash 

Player is ubiquitous these days. If the web browser doesn’t already have Flash installed, 

it’s easy to download and install it (see www.adobe.com/shockwave/download/download.cgi?

P1_Prod_Version=ShockwaveFlash).

When the Flash file is opened in a web browser, the presentation starts, as shown in 

Figure 25-6. You can progress through it by clicking anywhere on the screen.
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Figure 25-6. You can save any presentation as a Flash animation, which can be played back 

in a suitably equipped web browser.

Summary
In this chapter, we examined Impress, which is the presentations component within 

OpenOffice.org. We started by looking at how you can use the Presentation Wizard function 

to automate production of a basic Impress document. Then you saw how various effects 

can be added to the presentation, including 3D effects. Finally, we looked at how the 

presentation can be exported as a Shockwave Flash file for playback on virtually any web 

browser.

In the next chapter, we will explore the database component within OpenOffice.org: Base.


